Multiple vulnerabilities with TLS implementation and OCSP check’s fixed with the Apache security update. By exploiting the vulnerabilities a remote attacker can gain access to the server.
Apache Security Update
OCSP Invalid Response
OCSP responder Apache Tomcat Native failed in handling the invalid OCSP responses. The vulnerability allows the users with the revoked client certificates can authenticate when using mutual TLS.
The vulnerability affects 1.2.0 to 1.2.16 and 1.1.23 to 1.1.34 version and it has been fixed with revision 1832832. The vulnerability can be tracked as CVE-2018-8019.
Authentication with Revoked Certificates
Apache Tomcat Native failed in check OCSP pre-produced responses, which may impact in revoked certificate detection and the vulnerability allows the users with the revoked client certificates can authenticate when using mutual TLS.
The vulnerability affects 1.2.0 to 1.2.16 and 1.1.23 to 1.1.34 version and it has been fixed with revision 1832863. The vulnerability can be tracked as CVE-2018-8020.
OCSP Check Omitted
Apache Tomcat Native Connector 1.2.0 to 1.2.14 and 1.1.23 to 1.1.34 did not correctly handle fields longer than 127 bytes. The result of the parsing error was to skip the OCSP check. It allows a client that has been rejected to be accepted.
The vulnerability affects 1.2.0 to 1.2.14 and 1.1.23 to 1.1.34 version and it has been fixed with revision 1815200 and 1815218. The vulnerability can be tracked as CVE-2017-15698.
TLS SSL Man In The Middle
Not an Apache Tomcat Native vulnerability, if the APR/native connector uses OpenSSL version that is
vulnerable then APR/native connector is vulnerable also vulnerable and it allows attackers to inject arbitrary requests into a TLS stream during renegotiation.
Starting from version 1.1.18 client-initiated renegotiations are rejected to provide partial protection against this vulnerability with any OpenSSL version. The vulnerability can be tracked as CVE-2009-3555.
The vulnerability affects all OpenSSL version before 1.0.1 to 1.0.1f, it also a remote attacker to read certain contents of the server’s memory.
Tcnative version 1.1.24 – 1.1.29 includes the vulnerable version of the OpenSSL, starting from tcnative 1.1.30 it comes with the OpenSSL version that patched for this vulnerability. The vulnerability can be tracked as CVE-2014-0160.
Apache Software Foundation Releases Important Security Patches for Multiple Apache Tomcat Versions
Ubuntu Security Updates for Vulnerabilities that Affects Multiple Versions
VMware Released Critical Security Updates for Multiple Vulnerabilities Including L1 Terminal Fault