Critical Cisco Contact Center Bug Let Hackers Access Telephone Queues

Recently it has been reported that a critical vulnerability has been detected in the Unified Contact Center Enterprise (UCCE) portfolio of Cisco.

By exploiting this critical security flaw a hacker can easily get privilege-escalation and platform takeover through which could access the telephone queues remotely.

This critical vulnerability is tracked as CVE-2022-20658, and it has been marked as “Critical.” And UCCE (Unified Contact Center Enterprise) of Cisco supports up to 24,000 customer-service agents for performing the following things:-

In short, UCCE (Unified Contact Center Enterprise) of Cisco is an on-premises customer-service platform.

Flaw profile

  • CVE ID: CVE-2022-20658
  • Description: Cisco Unified Contact Center Management Portal and Unified Contact Center Domain Manager Privilege Escalation Vulnerability.
  • Advisory ID: cisco-sa-ccmp-priv-esc-JzhTFLm4
  • Cisco Bug IDs: CSCvz49473
  • CVSS Score: Base 9.6
  • Severity: Critical

Apart from this, since the beginning of January 2022, Cisco has already issued several security advisories. However, to address this critical vulnerability, Cisco has now rolled out the security updates for the:-

  • Unified Contact Center Management Portal (Unified CCMP)
  • Unified Contact Center Domain Manager (Unified CCDM)

Infection chain

By submitting a specially crafted HTTP request to a vulnerable system, this critical vulnerability could be exploited, and apart from this, this flaw exists due to the lack of server-side validation of user permissions.

While on the successful exploitation of this flaw, an attacker can easily get all the admin privileges and even create another administrator accounts as well.

Across all the Unified platforms, the threat actor can access and modify the telephony and user resources by using the accounts created.

Affected products

Here we have mentioned below the products that were affected by this flaw:-

  • Cisco Unified CCMP
  • Cisco Unified CCDM

Patches available

For this vulnerability, there are patches available, and here they are mentioned below:-

  • Versions 11.6.1 and earlier: Fixed release is 11.6.1 ES17
  • Version 12.0.1: Fixed release is 12.0.1 ES5
  • Version 12.5.1: Fixed release is 12.5.1 ES5
  • Version 12.6.1: Not affected

Moreover, till now there is no such trace of exploitation of this vulnerability has been reported, but cybersecurity researchers have strongly recommended users to upgrade to the latest version immediately.

You can follow us on LinkedinTwitterFacebook for daily Cybersecurity updates

Leave a Reply