Friday, May 24, 2024

Critical Cisco Expressway Flaw Let Remote Execute Arbitrary Code

Cisco released patches to address multiple vulnerabilities in the Cisco Expressway Series that might allow an attacker to do arbitrary operations on a vulnerable device.

Cisco Expressway Series includes Cisco Expressway Control (Expressway-C) and Cisco Expressway Edge (Expressway-E) devices.

“Multiple vulnerabilities in the Cisco Expressway Series could allow an unauthenticated, remote attacker to conduct cross-site request forgery (CSRF) attacks, which could allow the attacker to perform arbitrary actions on an affected device,” Cisco said.

An attacker may induce users into performing activities they do not intend to by using a web security flaw called cross-site request forgery, or CSRF.

Cisco patched the CSRF vulnerabilities identified as CVE-2024-20252 and CVE-2024-20254 (CVSS score: 9.6) with ‘critical’ severity and CVE-2024-20255 (CVSS score: 8.2) with ‘high’ severity ratings.

Document
Protect Your Network From Data Breach

Perimeter’s 81 Malware Protection for Network Based Threats

Prevent malware from infecting your network at the delivery stage by intercepting malicious files in transit from their source to the target device’s web browser..

Cisco Expressway Series CSRF

CVE-2024-20252 and CVE-2024-20254 

An unauthorized remote attacker may be able to launch CSRF attacks against a compromised system due to two vulnerabilities in the API of Cisco Expressway Series devices.

“These vulnerabilities are due to insufficient CSRF protections for the web-based management interface of an affected system. An attacker could exploit these vulnerabilities by persuading a user of the API to follow a crafted link”, Cisco said.

A successful vulnerability could allow the attacker to do arbitrary actions with the vulnerable user’s privileges. These activities could involve changing the system configuration and making new privileged accounts if the impacted user has administrative capabilities.

CVE-2024-20255

Cisco Expressway Series API vulnerability may enable a remote, unauthenticated attacker to launch a CSRF attack against a compromised system.

This vulnerability results from insufficient CSRF protections for a vulnerable system’s web-based management interface. An attacker could exploit this vulnerability by convincing an API user to click on a specially crafted link.

“A successful exploit could allow the attacker to perform arbitrary actions with the privilege level of the affected user. If the affected user has administrative privileges, these actions could include overwriting system configuration settings, which could prevent the system from processing calls properly and result in a denial of service (DoS) condition”, Cisco said.

Affected Products

 CVE-2024-20254 and CVE-2024-20255 impact Cisco Expressway Series devices when they are configured by default.

CVE-2024-20252: This vulnerability affects Cisco Expressway Series devices if the cluster database (CDB) API feature is enabled. By default, this feature is not enabled.

Fixes Released

Cisco Expressway Series Release    First Fixed Release
Earlier than 14.0Migrate to a fixed release.
14.014.3.4
15.015.0.0

Due to its end-of-support date, the Cisco Expressway Series no longer covers the Cisco TelePresence Video Communication Server (VCS).

Cisco has not published software upgrades for Cisco TelePresence VCS to fix the vulnerabilities, and it will not release any in the future.

Unified Communications Manager (CM) and Contact Center Solutions products are affected by a critical severity remote code execution weakness that Cisco announced in January. This lets the attackers run the command as a root user.

It is recommended that users upgrade to the latest version to prevent these vulnerabilities from getting exploited.

Stay updated on Cybersecurity news, Whitepapers, and Infographics. Follow us on LinkedIn & Twitter.

Website

Latest articles

Hackers Weaponizing Microsoft Access Documents To Execute Malicious Program

In multiple aggressive phishing attempts, the financially motivated organization UAC-0006 heavily targeted Ukraine, utilizing...

Microsoft Warns Of Storm-0539’s Aggressive Gift Card Theft

Gift cards are attractive to hackers since they provide quick monetization for stolen data...

Kinsing Malware Attacking Apache Tomcat Server With Vulnerabilities

The scalability and flexibility of cloud platforms recently boosted the emerging trend of cryptomining...

NSA Releases Guidance On Zero Trust Maturity To Secure Application From Attackers

Zero Trust Maturity measures the extent to which an organization has adopted and implemented...

Chinese Hackers Stay Hidden On Military And Government Networks For Six Years

Hackers target military and government networks for varied reasons, primarily related to spying, which...

DNSBomb : A New DoS Attack That Exploits DNS Queries

A new practical and powerful Denial of service attack has been discovered that exploits...

Malicious PyPI & NPM Packages Attacking MacOS Users

Cybersecurity researchers have identified a series of malicious software packages targeting MacOS users.These...
Guru baran
Guru baranhttps://gbhackers.com
Gurubaran is a co-founder of Cyber Security News and GBHackers On Security. He has 10+ years of experience as a Security Consultant, Editor, and Analyst in cybersecurity, technology, and communications.

Free Webinar

Live API Attack Simulation

94% of organizations experience security problems in production APIs, and one in five suffers a data breach. As a result, cyber-attacks on APIs increased from 35% in 2022 to 46% in 2023, and this trend continues to rise.
Key takeaways include:

  • An exploit of OWASP API Top 10 vulnerability
  • A brute force ATO (Account Takeover) attack on API
  • A DDoS attack on an API
  • Positive security model automation to prevent API attacks

Related Articles