Horde Webmail Client

Cybersecurity experts have urged companies and users to immediately change the default setting of the Horde Webmail who use the Horde Webmail application to view their emails.

As recently, it has been discovered that a default feature of Horde Webmail contains a nine-year-old unpatched security flaw that could be exploited by the threat actors to gain full access to the email accounts.

Here’s what the security analysts at Sonar Source, SIMON SCANNELL has stated:-

“We discovered a code vulnerability in Horde that allows an attacker to gain full access to the email account of a victim when it loads the preview of a harmless-looking email attachment.” 

“This gives the attacker access to all sensitive and perhaps secret information a victim has stored in their email account and could allow them to gain further access to the internal services of an organization.”

Horde Webmail app is one of the popular clients that comes pre-installed with the cPanel that is used by several hosting companies and millions of website admins.

A flaw in Horde Webmail

The flaw detected in Horde Webmail resides in one of the default features of the client which takes the OpenOffice documents and then creates previews to show them inside the browser.

This security flaw is an XSS vulnerability (cross-site scripting flaw) that was initially detected 9-years-ago with the commit 325a7ae. A malicious OpenOffice document can be crafted by an attacker which could be transformed to XHTML for preview by Horde.

Here, at this point when Horde generates the preview of the transformed XHTML can trigger the execution of a malicious JavaScript payload.

While Scannell added:-

“If an attacker succeeds in targeting an administrator with a personalized, malicious email, they could abuse this privileged access to take over the entire webmail server.”

However, due to an informal matching rule in an XSLT document, this XSS vulnerability emerges.  

No patch, but there’s a way to stop

Currently, there is no official patch available for this vulnerability, but, still you can block such attacks. What you have to do is:-

  • Inside the Horde webmail app, you have to disable the rendering of OpenOffice attachments.

You can follow us on LinkedinTwitterFacebook for daily Cybersecurity and hacking news updates.

LEAVE A REPLY

Please enter your comment!
Please enter your name here