Cyber Security News

JetBrains Warns of GitHub Plugin that Exposes Access Tokens

A critical vulnerability (CVE-2024-37051) in the JetBrains GitHub plugin for IntelliJ-based IDEs (2023.1 and later) exposed access tokens to malicious content within GitHub pull requests, allowing attackers to steal tokens and potentially compromise linked accounts, even with two-factor authentication enabled. 

JetBrains has addressed the issue with a patch and collaborated with GitHub on mitigation efforts.

Users are advised to update their IDEs and consider revoking any GitHub tokens used by the plugin. 

They have provided available fixed versions for JetBrains IDEs as of today, while Aqua currently has a single fixed version available, 2024.1.2.

With ANYRUN You can Analyze any URL, Files & Email for Malicious Activity : Start your Analysis

CLion offers multiple fixed versions, spanning from 2023.1.7 all the way up to the latest Early Access Program (EAP) build, 2024.2 EAP2. DataGrip and DataSpell each have a fixed version from the current year (2024.1.4 and 2024.1.2, respectively). 

GoLand and IntelliJ IDEA users benefit from a wider range of fixed versions, including those from 2023 and the current EAP builds for 2024.2.

Finally, MPS offers fixed versions starting in the middle of 2023 (2023.2.1), with the latest being an EAP build from the current year (2024.1 EAP2).  

A security vulnerability in the JetBrains GitHub plugin that could expose access tokens has been patched, which affects all IntelliJ-based IDEs (including PhpStorm, PyCharm, Rider, RubyMine, WebStorm, and RustRover) from version 2023.1 onwards. 

The JetBrains GitHub plugin has been updated with the fix, and insecure versions have been removed from the JetBrains Marketplace.

Users are strongly recommended to update the plugin to the latest version immediately. 

An external security report submitted on May 29, 2024, identified a vulnerability (CVE-2024-37051) in the JetBrains GitHub plugin for IntelliJ-based IDEs (version 2023.1 and later). 

The vulnerability could expose a user’s GitHub access token to a malicious third-party if a pull request containing malicious content is handled by the IDE, while updating to the latest IDE version is strongly recommended to mitigate this vulnerability. 

JetBrains identified a security vulnerability in their GitHub plugin for IntelliJ-based IDEs (versions 2023.1 and later) that could expose access tokens, and to mitigate this issue, they contacted GitHub and implemented measures that might cause the plugin to malfunction in older IDE versions. 

While a permanent fix is underway, updating the plugin and IDE to the latest versions is crucial to ensuring security and full functionality. 

To ensure compatibility and security when using the JetBrains IDE GitHub integration plugin, update to the latest IDE version, and if you’ve used the plugin’s pull request features, revoke any associated GitHub tokens. 

The plugin might use OAuth or Personal Access Tokens (PATs). Revoke them through GitHub’s application settings or token management page.

Note that revoking tokens disables all plugin features, including Git operations, requiring reconfiguration.

Looking for Full Data Breach Protection? Try Cynet's All-in-One Cybersecurity Platform for MSPs: Try Free Demo 

Aman Mishra

Recent Posts

Hackers Claiming Dettol Data Breach: 453,646 users Impacted

A significant data breach has been reported by a threat actor known as 'Hana,' who claims to have compromised the…

21 hours ago

CrowdStrike Update Triggers Widespread Windows BSOD Crashes

A recent update from cybersecurity firm CrowdStrike has caused significant disruptions for Windows users, leading to widespread reports of Blue…

1 day ago

Operation Spincaster Disrupts Approval Phishing Technique that Drains Victim’s Wallets

Chainalysis has launched Operation Spincaster, an initiative to disrupt approval phishing scams that have drained billions from victims' wallets. This…

1 day ago

Octo Tempest Know for Attacking VMWare ESXi Servers Added RansomHub & Qilin to Its Arsenal

Threat actors often attack VMware ESXi servers since they accommodate many virtual machines, which link to a variety of systems…

2 days ago

TAG-100 Actors Using Open-Source Tools To Attack Gov & Private Orgs

Hackers exploit open-source tools to execute attacks because they are readily available, well-documented, and often have extensive community support, making…

2 days ago

macOS Users Beware Of Weaponized Meeting App From North Korean Hackers

Meeting apps are often targeted and turned into weapons by hackers as they are largely employed for communication and collaboration,…

2 days ago