Cyber Security News

NVIDIA BlueField Flaw Lets VM Users Execute Code via Crafted Messages

NVIDIA has revealed a significant security vulnerability in its BlueField data processing units (DPUs) that could allow virtual machine (VM) users to execute arbitrary code through specially crafted network messages.

This raises serious concerns for cloud and virtualized infrastructure environments. The vulnerability, designated as CVE-2026-65094, impacts NVIDIA VIRTIO-Net implementations on BlueField-3 platforms and has a CVSS v3.1 base score of 9.0, indicating high severity with the potential for widespread impact in multi-tenant environments.

NVIDIA BlueField Flaw

According to NVIDIA’s security bulletin from July 2026, the vulnerability arises from a Write-What-Where condition (CWE-123) within the Virtio-Net component. Malicious VM users can exploit this flaw by sending crafted messages, allowing them to manipulate memory locations and achieve arbitrary code execution within the Virtio-Net scope.

The attack vector is classified as adjacent (AV:A), with low complexity and no user interaction required, making it particularly dangerous in shared environments where multiple tenants operate on the same hardware.

This issue is especially critical for cloud service providers, enterprise data centers, and high-performance computing environments that utilize NVIDIA BlueField DPUs for network offloading, storage acceleration, and infrastructure isolation.

Since BlueField DPUs are intended to enforce security boundaries between host systems and workloads, successful exploitation of this vulnerability could undermine these isolation guarantees, allowing attackers to pivot within the environment or disrupt essential services.

NVIDIA confirmed that the vulnerability was discovered internally and has released patched versions across multiple supported branches.

Affected versions include VIRTIO-Net GA releases prior to 25.10.6, LTS25 versions before 25.10.2, LTS24 versions prior to 24.10.50, and LTS23 versions up to 1.7.21.

Users are strongly encouraged to upgrade to the latest available versions: 25.10.6 (GA), 25.10.2 (LTS25), 24.10.50 (LTS24), or 23.10.23 (LTS23) to mitigate the risk.

While no active exploitation has been reported at the time of disclosure, the nature of the vulnerability, along with its low complexity and high impact, makes it a prime target for future attacks.

Security teams should prioritize patching, review VM isolation controls, and monitor for unusual Virtio-Net traffic patterns as part of their detection strategy. This disclosure emphasizes the growing attack surface within modern DPU-accelerated environments and highlights the need for ongoing security validation in virtualized networking stacks.

ALERT: 20+ government sites delivered malware to businesses and citizens. See full attack research to check your own exposure.

Divya

Divya is a Senior Journalist at GBhackers covering Cyber Attacks, Threats, Breaches, Vulnerabilities and other happenings in the cyber world.

Recent Posts

OpenSSH sshole Flaw Allows Hackers to Log Into Password-Disabled Linux Accounts Using 257-Character Passwords

A decade-old authentication bypass in OpenSSH on musl-based Linux lets attackers log into accounts that…

2 minutes ago

New GhostMap Android Vulnerability Can Crash Phones Permanently Without Opening an App or Granting Permissions

Bitdefender researchers have revealed a vulnerability called GhostMap that affects Android devices. This vulnerability can…

11 minutes ago

Microsoft Paint Vulnerability Allows Hackers to Execute Malicious Code Remotely Without User Interaction

Microsoft has announced a vulnerability in Windows Paint that could let unauthenticated attackers execute malicious…

35 minutes ago

ARTEX AI Framework Linked to Bank Breaches and Cloud Attacks Found Exposed Across Hundreds of Servers

An autonomous penetration-testing framework linked to South Korean banking breaches and cloud supply-chain attacks is…

1 hour ago

Shopify Makes IP Allowlisting Mandatory for All Public Apps to Prevent Stolen API Token Abuse

Shopify is making IP allowlisting mandatory for all public apps to limit abuse of stolen…

1 hour ago

OpenAI’s New GPT-6 Cyber Finds 81 High-Severity Firefox Vulnerabilities and 948 Linux Kernel Exploits

OpenAI has introduced GPT-6 Cyber, a security-focused model built to find and validate exploitable vulnerabilities…

1 hour ago