VLC 3.0.11

VideoLan released VLC 3.0.11 that fixes code execution vulnerability with VLC media player 3.0.10 and earlier versions.

The vulnerability can be tracked as CVE-2020-13428, a remote attacker can trigger a buffer overflow in VLC’s H26X packetizer by using a specifically crafted file.

Successful exploitation of the vulnerability could result in a crash of VLC media player or results in arbitrary code execution with the privileges of the target user.

“While these issues in themselves are most likely to just crash the player, we can’t exclude that they could be combined to leak user information or remotely execute code. ASLR and DEP help reduce the likeliness of code execution, but maybe bypassed,” reads the advisory.

To exploit the vulnerability the targeted user needs to explicitly open the specially crafted file or stream.

VideoLan confirms that “We have not seen exploits performing code execution through these vulnerabilities.”

Users are recommended to update with VLC media player 3.0.11 to addresses the issue. As workaround users are recommended not to open files from untrusted sources.

Now VLC 3.0.11 is available for Windows, macOS, Android, iOS, Windows Phone, and for Linux distributions.

VLC is a highly portable multimedia player that supports an enormous number of multimedia formats, without downloading any additional codecs.

Following are the Fixes with 3.0.11

VLC 3.0.11 is the twelfth update of "Vetinari":
Fixes HLS regressions
Fixes a potential crash on startup on macOS
Fixes imprecise seeking in m4a files
Fixes resampling on Android
Fixes a crash when listing Bluray mount points on macOS
Avoid unnecessary permission warnings on macOS
Fixes permanent silence on macOS after pausing playback
Fixes AAC playback regression
And a security issue

Complete change log can be found here.

You can follow us on LinkedinTwitterFacebook for daily Cybersecurity and hacking news updates.

Also Read

Vulnerability with VLC for iOS Allows Attackers to Steal Data from Storage

VideoLAN Fixed 13 VLC Media Player Vulnerabilities that allow Attackers to Execute Arbitrary Code Remotely

Critical Vulnerability in VLC Media Player 3.0.7.1 Let Hackers to Execute Arbitrary Code

1 COMMENT

  1. thank you so much for what you do, fortunately because of your coverage i’m well ahead of the curve on getting hacked.

Leave a Reply