Critical Jira Vulnerability

In an advisory published by Atlassian, the company warns that critical vulnerabilities in Seraph affect its Jira and Jira Service Management products.

Seraph is a framework that secures web applications provided by the company, and with Seraph, all login and logout requests for Jira and Confluence are handled through pluggable core elements.

Critical Vulnerability

The critical vulnerability has been tracked as CVE-2022-0540 with a severity score of 9.9 out of 10 on the CVSS scoring system.

While the threat actors could exploit this critical vulnerability by transmitting a specially crafted HTTP plea to the vulnerable endpoints remotely to bypass authentication.

Affected Products

Here below we have mentioned all the affected products and their versions:-

  • Jira Core Server, Software Server, and Software Data Center before 8.13.18, the 8.14.x, 8.15.x, 8.16.x, 8.17.x, 8.18.x, 8.19.x, 8.20.x before 8.20.6, and 8.21.x.
  • Jira Service Management Server and Management Data Center before 4.13.18, the 4.14.x, 4.15.x, 4.16.x, 4.17.x, 4.18.x, 4.19.x, 4.20.x before 4.20.6, 4.21.x.

While the Jira Service Management and Jira Cloud versions are not vulnerable to this vulnerability. Moreover, if the remote attackers employ a specific configuration in Seraph then can compromise the affected products only.

Vulnerable Apps

This vulnerability has affected two bundled apps for Jira, and here they are mentioned below:-

  • Insight – Asset Management
  • Mobile Plugin

In addition to Atlassian Marketplace apps, third-party apps, like those developed by customers or not listed on the Atlassian Marketplace, are also at risk if they rely on vulnerable configurations.


Security updates are included in the following versions:-

For Jira Core Server, Software Server, and Software Data Center the fixed versions are:

  • 8.13.x >= 8.13.18, 8.20.x >= 8.20.6, and all versions from 8.22.0 and later.

For Jira Service Management, the fixed versions are: 

  • 4.13.x >= 4.13.18, 4.20.x >= 4.20.6, and 4.22.0 and later.

It is highly recommended that users update to one of the above versions as soon as possible to mitigate potential exploitation.

Depending on the availability of immediate patches, the company is offering two options: 

  • Updating affected apps to the latest version.


  • Disabling them altogether.

Apart from this, it is worth noting that an Atlassian Confluence vulnerability that was actively exploited last year to install cryptocurrency miners was a critical remote code execution bug.

You can follow us on LinkedinTwitterFacebook for daily Cybersecurity and hacking news updates.


Please enter your comment!
Please enter your name here